Create A Forum - Support Forums

Support => Bugs => Topic started by: stolph on December 20, 2017, 12:00:19 am

Title: Can't embed my forum in my site with iframe
Post by: stolph on December 20, 2017, 12:00:19 am
Hi very new here...

I've seen several posts about this but no one got a resolution. I cannot embed an iframe to my forum on my website:

<iframe width="1000" height="1000" src="https://scabard.createaforum.com/index.php"></iframe>

When I look at console log in chrome developer tools it's because I'm getting this error from createaforum.com server:

Refused to display 'https://scabard.createaforum.com/index.php' in a frame because it set 'X-Frame-Options' to 'sameorigin'.

Is it intentional that you block embedding forums in a website? If so, why? Is it available with a paid subscription?
Title: Re: Can't embed my forum in my site with iframe
Post by: CreateAForum on December 20, 2017, 12:04:53 am
I can allow it on a site basis maybe... The reason is for security. There some security issues that can be carried out on iframe that can be somewhat worrysome I just added that security recently.
Title: Re: Can't embed my forum in my site with iframe
Post by: stolph on December 20, 2017, 12:09:28 am
Thanks for the quick response! Our site is https://www.scabard.com (https://www.scabard.com/pbs for redesign) if you want to check us out and are willing to add us to the list. I promise not to do anything bad.
Title: Re: Can't embed my forum in my site with iframe
Post by: CreateAForum on December 20, 2017, 10:17:06 pm
Added an option to allow iframe embeding under Admin -> Forum Settings
You have to check that for your forum.
Title: Re: Can't embed my forum in my site with iframe
Post by: stolph on December 20, 2017, 11:42:58 pm
Works perfectly. Thanks!  :)