Author Topic: Embedding forms into a topic post... possible?  (Read 922 times)

0 Members and 0 Guests are viewing this topic.

Offline 65Wolf

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Embedding forms into a topic post... possible?
« on: January 09, 2012, 09:05:49 am »
We have an online application form we use (from google.docs) which people access to submit us information.  I would love to embed that form into a message post on the boards so that users can complete it within that message and submit it, and not be redirected away from our forums.  We figured out how to set the Topic to redirect the user directly to that Application Form page, but that takes the user away from our forums. 
 
Is there a way to embed that form into a message, or better yet, have the link in the message just open a new window for the form they need to submit, which would allow them to still stay on our forums once they submit and close their application form? 
 
I have tried several things, but am not finding anything that really accomplishes this.   The only other option is to use the link in the message.  But this, too, will redirect the user away from the site. We have no way to ensure they get back to our site after they leave the application form.
 
Thanks for your assistance!
 
 
Am I not doing something correctly?  Or is it not possible to do what I am trying to do in a post?

Share on Facebook Share on Twitter


Offline CreateAForum

  • Administrator
  • *****
  • Posts: 6304
  • Karma: 298
    • View Profile
Re: Embedding forms into a topic post... possible?
« Reply #1 on: January 09, 2012, 03:30:19 pm »
There is no way to embed a form into a  post since that would cause a form inside  a form issue. You would need to link to a form page/site.
Like Create A Forum? Support me at https://www.patreon.com/vbgamer45/

Offline aIURbliS

  • Hero Member
  • *****
  • Posts: 1215
  • Karma: 45
  • Gender: Male
  • Location: U.S.
    • View Profile
Re: Embedding forms into a topic post... possible?
« Reply #2 on: January 09, 2012, 11:10:38 pm »
Actually it's possible to do it if you use a webpage on your forum instead and I'll iframe the google docs. Or you can use a webpage on your forum and put in the following code to open google docs in a new window:
Code: [Select]
<a href="URL" target="_blank">TEXT</a>
« Last Edit: January 09, 2012, 11:16:24 pm by xboi209 »
All codes I make are tested on the latest version of Google Chrome and upon request of other browsers.

Offline 65Wolf

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Embedding forms into a topic post... possible?
« Reply #3 on: January 09, 2012, 11:24:59 pm »
(Quote feature didn't work.. .hmm)
 
xboi209:
 
Do you mean like utilize the portal page with the forums? Or make a post page under the appropriate topic and then iframe it into that somehow?  Or what/how exaclty?
 
My other thought is to make a simple website, linked to my domain, then have it link to the forums from there.  That way, I could add a few imformative pages to the Main Page, including the form we want to use, and embed it as such.  We are used to using subdomains (aliases) for our forums, not the top level domain (TLD).  Unfortunately, we don't have our server upgraded as we would like to as of yet in order to start putting this all in-house.  This would certainly be the answer to all my problems!  We would be able to have it all in one place making it so much easier to do what we want.  :)
 
For now, it seems the simplest way (and the least work) would be for us to do it in the forums, if possible.   
 
Thanks again for the help!

Offline aIURbliS

  • Hero Member
  • *****
  • Posts: 1215
  • Karma: 45
  • Gender: Male
  • Location: U.S.
    • View Profile
Re: Embedding forms into a topic post... possible?
« Reply #4 on: January 09, 2012, 11:34:32 pm »
Actually you can make a simple website and I can iframe that. Look in your admin panel on the left side, there will be a title called EzPortal and 3 links under that title. Click on the link that says Page manager. From there, you can create custom pages for your forum. Create a custom page that's blank and then tell me the link of that custom page and the link of the page you want to iframe.
All codes I make are tested on the latest version of Google Chrome and upon request of other browsers.

Offline 65Wolf

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Embedding forms into a topic post... possible?
« Reply #5 on: January 09, 2012, 11:38:48 pm »
That sounds perfect!  Let me play with that a little bit and I'll get back to you when ready!  Thanks for yor time and assistance!!  I really appreciate it!!

Offline 65Wolf

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Embedding forms into a topic post... possible?
« Reply #6 on: January 10, 2012, 09:10:08 am »
Alright, got my page created. 
 
Page is at:   http://wolfcraft.createaforum.com/index.php?action=ezportal;sa=page;p=1
 
 
I couldn't do a blank page, so I placed the link to the form in the page.  Will I be able to edit anything else above or below the form once you place it in the iframe?
 
The link to my form I want embedded into our webpage is:
 
https://docs.google.com/spreadsheet/viewform?hl=en_US&formkey=dFFhZ0FYNjRfVkRFTHlydV9kcXhYT1E6MQ#gid=0
 
Thanks again for your assistance!!
 
------------------------------------------------
 
 
On another note: 
 
I know its not related to this topic, but odd thing I noticed today.  Not sure if was like that before or not.  I have started a Portal page.   Some time after I did so, I noticed something odd.  Not sure it was like this before I created these new webpages and Portal, or not.  But now, when I go to either the portal or the forums, it shows the hierarchy line (or whatever you call it) which is left justified just below the NavBar and  just above the top of the forums (or just above the top EzBlock in the Portal), appearing as:
 
WolfCraft Gaming Network Forum WolfCraft Gaming Network
 
This seems redundant and doesn't seem like it should be right.  If you click on either of the "WolfCraft Gaming Network" instances, they both take you to the Portal Page.  And the "Forum" link will go to the Forum Main Page.  So the second portal page is showing up between the main forum page and the category page when you continue into the forums.
 
Because then, when you go into a Forum category, it shows:
 
WolfCraft Gaming Network Forum WolfCraft Gaming Network WolfCraft Community
 
Repeating the Forum title (WolfCraft Gaming Network) again after "Forum" appears.
Maybe its just me, but it shouldn't be appearing again after the "Forum" appears when you are on the Forums, right?  And it also shows that just when I'm just in the Portal. Shouldn't it show just the first:
 
WolfCraft Gaming Network     
 
as such, on the portal page?
 
---------------------------
 
And then after I go to forums, it shouldn appear like this:
 
WolfCraft Gaming Network Forum
 
And then into the Category "WolfCraft Community", it should be:
 
WolfCraft Gaming Network Forum WolfCraft Community 
 
But it mistakely shows up as:
 
WolfCraft Gaming Network Forum WolfCraft Gaming Network WolfCraft Community
 

-------------------------------------
 
So I am confused on why it repreats the WolfCraft Gaming Network (which is the Forum Title linking to the Portal page) twice, both in front of and behind "Forum". 
 

I tried to replace the Forum Title (WolfCraft Gaming Network), in the respective Admin section, with the word "test" and that word came up in place of both the "WolfCraft Gaming Network" titles.  This is how it looked when I went to that sub-category again:
 
test Forum test WolfCraft Community Introductions
 
Any ideas where I need to look to fix this so it doesn't repeat incorrectly?
 
Thanks much!  I should be set once I figure this out now! support
« Last Edit: January 10, 2012, 09:26:10 am by 65Wolf »

Offline aIURbliS

  • Hero Member
  • *****
  • Posts: 1215
  • Karma: 45
  • Gender: Male
  • Location: U.S.
    • View Profile
Re: Embedding forms into a topic post... possible?
« Reply #7 on: January 11, 2012, 04:15:42 am »
Just finalized the code now:
Headers:
Code: [Select]
<script src="http://code.jquery.com/jquery.js"></script>
Footers:
Code: [Select]
<script type="text/javascript">
if(/action=ezportal;sa=page;p=1/i.test(location.href)){
$("div.navigate_section").after("<iframe src='https://docs.google.com/spreadsheet/viewform?hl=en_US&formkey=dFFhZ0FYNjRfVkRFTHlydV9kcXhYT1E6MQ#gid=0' height='3100px' width='100%'>");
};
</script>


If you know how to edit that code, you can edit and put things there as much as you want, otherwise use the webpage editor or edit the google docs again. For the second issue, post in the bugs or suggestions board instead.
« Last Edit: January 11, 2012, 04:18:20 am by xboi209 »
All codes I make are tested on the latest version of Google Chrome and upon request of other browsers.

Offline 65Wolf

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: Embedding forms into a topic post... possible?
« Reply #8 on: January 11, 2012, 04:47:30 am »
Ok, thanks much!!

 

Related Topics

  Subject / Started by Replies Last post
2 Replies
513 Views
Last post December 20, 2013, 02:30:39 am
by erica65404
2 Replies
851 Views
Last post December 15, 2014, 05:54:30 pm
by walkatha
6 Replies
691 Views
Last post April 04, 2015, 05:03:39 pm
by conductor
1 Replies
226 Views
Last post April 06, 2016, 12:56:20 pm
by CreateAForum
1 Replies
630 Views
Last post August 19, 2018, 10:34:45 pm
by CreateAForum